Jump to content
Acne.org
Search In
Find results that contain...
Find results in...
mawhinney98

Failed blood test for Accutane?

I had my blood tests done last Friday to go back on Accutane because my acne has come back.

Everything was fine except my Liver Enzyme Reading. It was at 90, whatever that means.

I go back on Friday to try again. I was really disheartened. I'm trying to figure out what could have caused this.

Things to note:

I was pretty sore from the gym. I started going back last week.

I didn't fast. I had a lot of fatty food the night before and in the morning a few hours before. 

I had a big protein shake the night before and a few days before that too.

Could this have been why my liver reading was so high? I don't think my liver is in a bad way. I drink plenty of water and I feel fine. I also barely drink alcohol and haven't had any for weeks.

Please someone give me some reassurance :( Thanks.

Edited by mawhinney98
Adding in

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Personalized Advice Quiz - All of Acne.org in just a few minutes


×