Jump to content
Acne.org
Search In
Find results that contain...
Find results in...

This is about a month before I started Accutane...

My derm said this is probably a staph infection.

After a while of treatment not working, and 4 months of it being there, I finally had a culture done to figure out what it really is. I havent gotten my results back yet. I'll post gradual pictures. Its been getting better with some sort of cream but its just now tiny bumps that dont seem to go away.

    From the album:

    The Accutane Adventure

    • 16 pictures
    • 0 comments
    • 22 image comments

    Photo Information for This is about a month before I started Accutane...


    Recommended Comments

    when are you starting accutane?? from the results other people have gotten from accutane, something tells me it'd work wonders for your skin!! i'm only on week 2 and am not sure where i'm headed yet.... good luck!

    Share this comment


    Link to comment

    Hi,

    I just wanted to say that it looks similar to what I had. My staph tested negative????? So who knows. But I am in my 4th month of tane and it really helped. so hang in there I know how awful it feels. Check out my pics in the gallery and see how bad mine was too. I need to post new pics;)

    Share this comment


    Link to comment

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a New Account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×